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Abstract

Menu system design for user interfaces is a
challenging task involving many design options
and various human factors. For example, one
crucial factor that designers need to consider is
the semantic and systematic relation of menu
commands. However, capturing these relations
can be challenging due to limited available re-
sources. Large language models can be helpful
in this regard, using their pre-training knowl-
edge to design and refine menu systems.

In this paper, we propose MenuCraft, an Al-
assisted designer for menu design that enables
collaboration between the designer and a di-
alogue system to design menus. MenuCraft
offers an interactive language-based menu de-
sign tool that simplifies the menu design pro-
cess and enables easy customization of design
options. MenuCraft supports a variety of inter-
actions through dialog that allows performing
in-context learning.

1 Introduction

Menus are widely used interfaces, providing users
with intuitive and efficient access to an applica-
tion’s functions. Although menus may seem sim-
ple at first glance, creating a well-designed menu
system is complex. This is because the number
of alternative designs grows exponentially as the
number of commands increases. In this paper, we
disregard non-textual design factors such as size,
saliency, and color, and only focus on the textual
representation of menu systems. From this perspec-
tive, the position of commands in the menu and the
assignment of hotkeys are the two most important
factors in designing a menu system. Menus typi-
cally follow a consistent linear pattern, where com-
mand names are displayed on the left and keyboard
shortcut cues are aligned on the right (Giannisakis
etal., 2022).

Since 1980, Human-Computer Interaction (HCI)
researchers have been developing better tech-

niques for placing commands within the menu sys-
tem. The ultimate goal is to minimize selection
time (Ahlstrom, 2005; Bailly et al., 2016; Card
et al., 1980) while maximizing the associativity
among commands (Bailly et al., 2013; Dayama
et al., 2021). To reach these goals, parameter-based
models are proposed. These models require com-
plete information regarding the frequency of com-
mand usage and the relation among commands
(e.g., pairwise semantic relevance scores (Bailly
et al., 2014; Chen et al., 2015)) before starting the
optimization process. The designer typically pro-
vides the parameters for menu system design. This
means that designers must rely on user testing and
past experience by comparing commands with each
other to determine the parameters. However, as the
number of commands increases, this process can
become increasingly challenging, time-consuming,
and prone to inaccuracy. Furthermore, designers
strive to maintain consistency across menus within
a given ecosystem. This involves placing com-
mands similarly across menus to help users quickly
locate the desired command. The downside is that
this process of ensuring consistency can be time-
consuming and distract designers from their pri-
mary goal of optimizing the menu.

Prior research has investigated using data-
driven methods such as pre-trained static embed-
dings (Adar et al., 2014; Li et al., 2018) to cap-
ture the semantics of menu commands. However,
these embeddings are typically trained on generic
datasets such as Wikipedia or limited program-
specific data. Consequently, these embeddings may
not effectively capture the systemic or semantic
relationships specific to the domain of menu sys-
tems, resulting in limited applicability. Despite the
advancements in neural language models, menu de-
sign using data-driven methods has not kept pace.
There are two main reasons for this: (i) the cost of
providing datasets for menu design is high, and

(i) menu design is an interactive process that re-



quires input, feedback, and adjustments from the
designer. Parameter-based models give designers
a sense of control over the output, and their pre-
dictability allows for a clearer understanding of
how different inputs will impact the final design.
Therefore, parameter-based methods are preferred
over data-driven methods in menu design.

Recent advancements in large language models
(LLMs), such as GPT-3 (Brown et al., 2020) and
PalLM (Chowdhery et al., 2022), have shown emer-
gent abilities (Wei et al., 2022a) to adapt to a range
of different tasks with zero or just a few examples
of the target task. The in-depth knowledge of these
models presents an exciting opportunity to facil-
itate the menu design process without requiring
extensive training or specific datasets. The conver-
sational nature of open-domain dialogue systems
built on top of these models can also serve to fulfill
the interactive demands of design.

In this work, we present MENUCRAFT, an Al as-
sistant that incorporates an open-domain dialogue
language model to design menus. MenuCraft lever-
ages the effectiveness of data-driven methods while
maintaining interactive design procedures. With
MenuCraft, designers can easily create menus, re-
ceive suggestions from the assistant, and ask for ad-
justments to enhance their menu design. For an as-
sistant to be useful in menu system design, it needs
to be versatile enough to handle a variety of tasks,
ranging from the simple, like adding a command
to a menu tab, to complex ones, such as suggesting
alternative designs, grouping commands, and ap-
plying restrictions to the menu, tabs, or individual
commands. To avoid the cost of collecting data
and training multiple models for different tasks,
we propose using the in-context learning method,
where the task is presented to the language model
as part of the prompt in natural language. Our tool
facilitates various menu design tasks, including
topic and command-based menu design, and pro-
vides recommendations for commands and hotkeys.
Furthermore, our tool enables designers to easily
create custom tasks, providing them with the flex-
ibility to tailor the system to their specific needs.
From an HCI viewpoint, we intend to use Menu-
Craft to study how designers engage with language
models, the types of tasks they request, and the
efficacy of the models in fulfilling those requests.
Our contributions:

1) We present a platform for collaborative menu
design between a human designer and an LLM (see

an example of a designer interacting with the pro-
totype version of MenuCraft at kargaranamir.
github.io/MenuCraft).

2) We illustrate how in-context learning can offer
a range of interactive menu design experiences, all
without requiring additional model training (see
limitations in §6).

2 Related Work

2.1 Bridging Menus and Natural Language

Menu systems can be categorized as a user inter-
face (UI) type. In this sense, significant research
in this area has been aimed at bridging graphical
UlIs (GUIs) with natural language. For instance,
some studies have focused on predicting alt-text
labels for GUI components (Li et al., 2020; Zhang
et al., 2021) or generating text summaries for the
entire screen (Leiva et al., 2022; Wang et al., 2021).
However, these approaches may not be well-suited
for menu systems due to the limitation of capturing
the entire menu in a single Ul screenshot. Addition-
ally, these researches have been focused on con-
necting the graphical aspects of the UI to natural
language, not addressing the structural characteris-
tics of menus or their textual representations.

Despite the potential benefits of bridging menu
systems and natural language, there has been lim-
ited research in this area. One possible explana-
tion for this is the lack of comprehensive textual
datasets for menu systems since most data about
different menu system applications are dispersed
across the internet or embedded within software
applications. In an attempt to gather a dataset for
menu systems, Bailly and Malacria (2013) has suc-
ceeded in building a menu-logger tool to extract
the hierarchies of the menu system for Mac OS
X applications. Bailly et al. (2013) provide an
open dataset of 68 applications gathered with this
tool to compute associativity score between the
commands. Nevertheless, this data only contains
limited data on menu system hierarchies for Mac
OS X applications and no descriptions or informa-
tion about commands. In another attempt, Adar
et al. (2014) train a word2vec model to capture the
domain-specific language of Photoshop application
by mining a large corpus of web documents related
to the application. However, the static representa-
tions derived from the trained model are limited to
a specific application domain.

There is a noticeable gap in research on in-
tegrating menu systems with natural language
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processing. Our work contributes to this gap
by leveraging the in-context learning capabil-
ity of LLMs to apply their extensive knowl-
edge to various menu design tasks. Our method
does not need additional datasets or training.

2.2 Interactive Application of LL.Ms

Language models, especially LLMs, have the po-
tential to be effectively used for in-context learning.
LLMs facilitate in-context zero/few-shot learning
through prompting. Rather than finetune or retrain
models for each new task, a few input and output
data examples (or just the instruction without ex-
amples) from the target task can be provided as
prompts to the LLM (Brown et al., 2020; Chowd-
hery et al., 2022; Wei et al., 2022b; Zhou et al.,
2022). This advantage enables these models to not
require explicit training and can support a variety
of creative tasks, especially in HCI research (Mor-
ris et al., 2022), such as story writing (Chung et al.,
2022; Coenen et al., 2021; Yuan et al., 2022), mod-
ifying web designs (Kim et al., 2022), conversa-
tional interactions on mobile Uls (Wang et al.,
2022), email writing (Goodman et al., 2022) and
executing robot commands (Ahn et al., 2022). To
the best of our knowledge, no one has yet attempted
to use language models for menu design. Our
platform proposes using language models in di-
alogue, which leverage pre-existing knowledge and
interactive design process .

3 The MenuCraft

MenuCraft is an interactive assistant tool designed
to assist designers in creating menu designs from
scratch, offering alternative designs, command and
hotkey suggestions, and more. The user-friendly
web interface of MenuCraft is designed as a tradi-
tional chatbot, enabling users to engage with the
tool seamlessly. Additionally, MenuCraft provides
a variety of default supported interactions that can
be conveniently inserted into the chat feed as tem-
plates. Users can easily modify the prompts to suit
their queries, allowing for a customized experience
catering to individual needs.

MenuCraft’s remarkable capabilities result from
using open-ended dialog systems built on LLMs.
The chosen dialog system does not undergo any
training on our part. The dialog system we use
is ChatGPT (OpenAl, 2022), later known as GPT-
3.5-turbo (Feb 13, 2023 release), a language model
capable of following instructions and answering

questions posed in a conversational format.

3.1 Initialize

ChatGPT is designed to take as input the previous
turns in a conversation and use them to generate a
prediction for the subsequent turn. For MenuCraft,
in-context zero/few-shot learning is formulated as
a conversation between a human designer and an
Al assistant. In our initial tests, we found it very
convenient to use this dialog model, as humans
are familiar with the conversational format and can
quickly adapt to it.

To set the initial prompt, we determined the pri-
mary goals of MenuCraft. As previously stated, the
objective of optimizing the arrangement of com-
mands is to improve selection time and enhance
the associativity among the commands. Usually,
frequently used commands are prioritized to re-
duce selection time by placing them at the top of
the menu based on Fitts’ Law (Ahlstrom, 2005;
Bailly et al., 2013; Cockburn et al., 2007). This
approach minimizes the time required for users to
access commonly used commands. To maximize
associativity, commands with related operations
are grouped and placed within the same tab and
near each other (Bailly et al., 2013). This meets
the user’s expectation of finding related menu com-
mands in familiar locations due to spatial mem-
ory (Cockburn et al., 2007). For instance, it is
intuitive that users expect to see commands such as
Cut, Copy, and Paste to be grouped or About and
Help commands to be located within the last tab.

With these objectives in mind, we formulated our
initial prompt as follows:

Initial Prompt

I want you to act as an AI-Assisted Menu
Designer, called MenuCraft. You will come
up with design ideas for menu user inter-—
faces that make apps easier to use. You
may suggest menu design apps for a topic,
arrange commands as linear or hierarchal
menus, group the commands as tabs, sug-
gest command names, add or suggest hot keys
for the commands, and so on - but the aim
is to design a menu that users find sat-
isfying to use, meaning select good names
for commands, prioritize frequently used
commands for each tab of menu as the top,
and put commands with close logical opera-
tions in the same tab. If you understand the
your responsibilities, introduce yourself
in short and asks for the user request.

MenuCraft responds with:



MenuCraft

I am MenuCraft, an AI-Assisted Menu De-
signer designed to help create intuitive
and user—-friendly menu interfaces for var-—
ious types of applications. I can suggest
menu design ideas, arrange commands in
linear or hierarchical menus, group com-—
mands as tabs, suggest command names, and
hotkeys, and more to make the app easier
to use. What would you like me to help you
with?

Now that initialization has been completed, design
requests can be submitted.

4 Supported Interactions

In this section, we describe a number of the inter-
actions that MenuCraft can perform.

4.1 Topic-Based Design

Topic-based design is one of the most general tasks
that a designer can ask MenuCraft to perform.
MenuCraft can assist in the creation of a menu for
a specific topic by suggesting relevant commands
based on similar apps and user input constraints.
For example, when MenuCraft is prompted with:

Human Designer

Create a menu for a text editor applica-
tion with 3 tabs. There should be a "Find~
command in the "Edit™ tab in the app. Tabs
should not have more than 6 commands each.
Please answer in the following format:

json
Tab: list of commands

MenuCraft responds with:

MenuCraft: Topic-Based Design

Certainly! Here's a menu design for a text
editor application with 3 tabs, including
the "Find® command in the "Edit” tab, and no
more than 6 commands per tab:

{"File":
["New", "Open", "Save", "Save As...",
"Print", "Exit"],
"Edit":
["UndO'l, "Redoll’ "cut", "Copy",
"Paste", "Find"],
"Format":
["Font", "Bold", "Italic", "Underline",

"Strikethrough", "Highlight"]}

This response completely fulfilled the request
and met the conditions. The designer can
continue the interactions for the new requests or
modifying the suggested menu. For example, de-
signer can request the Format tab be deleted, and in
its place the View tab and any commands required
be added:

Human Designer
Remove the "Format™ tab from the current de-
sign and replace it with a “View™ tab with
the commands that are needed.

MenuCraft responds with the same menu, replacing
the Format Tab with View Tab. The replaced tab
(other tabs were not shown for better readability):

MenuCraft: Modify Design

"View":
["Zoom In", "Zoom Out", "Full Screen",
"Show/Hide Ruler",
"Show/Hide Gridlines,
"Show/Hide Document Outline"]

The View tab has been successfully added with
relevant commands, such as Zoom In and Zoom
Out.

4.2 Command-Based Design

Command-based design is the primary focus within
the menu design community. In this scenario, the
designer provides a set of commands and their cor-
responding parameters, including the frequency of
usage for each command and the association score
between each pair of commands. Given the param-
eters, the designer then requests a menu optimizer
to provide an optimal or sub-optimal design. As
the number of commands increases, optimization
methods may take hours or even days to find an op-
timal solution. Conversely, while language model
approaches may not yield the optimal answer, they
can likely provide an appropriate one within sec-
onds. Furthermore, unlike optimization methods,
language models do not require access to the entire
set of parameters but welcome any input from the
designer. For example, when MenuCraft prompted
with random order of 5 tabs and 29 commands
of Windows Notepad application, without saying
these commands belong to this application:

Human Designer

Design a menu for a text editor app only
based on the provided commands and tabs.
Each tab should have the most frequently
used commands as its top, and commands with
close logical operations should be grouped
together as tabs. To show some of the com-—
mands in a tab are more related, you may use
some subgroups for each tab.



Commands provided (unordered) :

["View Help™, “About Application”, “Paste”,
“Save As™, “Open”, ...]

Tabs provided (unordered) :

["Format™, “File", “View™, “Help~, "Edit"]
Please answer in the following format:

" Json

Tab: list of commands

MenuCraft responds with:

MenuCraft: Command-Based Desgin

Here's a suggested menu design for a text
editor app based on the provided commands
and tabs:

{File:
["New", "New Window", "Open",
"Save", "Save As", "Page Setup", "Print",
llExitll],
Edit:
["Ul’ldO", Ilcutll’ "Copy", "Paste",
"Delete", {"Find": ["Find...",
"Find Next", "Find Previous",
"Replace..."]}, "Select All",
"Time/Date"],
Format:
["Word Wrap", "Font..."],
View:
[{"Zoom": ["Zoom In", "Zoom Out",
"Restore Default Zoom"]}, "Status Bar"],
Help:

["View Help", "Search With Bing",
"Send Feedback",
{"About": ["About Application"]} 1}

In this menu design, the commands are
arranged in hierarchical order with fre-
quently used commands appearing at the top
of each tab. The File tab includes essen-—
tial file-related actions such as creat-
ing, opening, saving, and printing files.
The Edit tab includes common text-editing
actions such as undo, copy, paste, and
find/replace. The Format tab includes op-
tions for formatting text, including word
wrap and font selection. The View tab in-
cludes commands for adjusting the zoom
level and displaying the status bar. The
Help tab includes options for getting help,
searching for information, and providing

feedback. | )
I hope this menu design meets your needs

and provides a user—friendly interface for
your text editor app!

This design has a lot in common with the original
Windows Notepad design. The commands’ order
and grouping are the same except for a few com-
mands. For example, Search With Bing is now
located under the Help tab, which may not be a bad
idea. In the following, MenuCraft explains why it
chose this particular design. The designer can al-
ways ask for the reasoning behind the design or ask
the MenuCraft to think step-by-step and explain
why it is taking each action.

4.3 Command or Tab Recommendation

MenuCraft can provide valuable suggestions for
related commands or tabs for a particular design.
This can save designers time and effort while also
improving the overall user experience of the design.
For example, asking MenuCraft about related com-
mands under a tab and why these commands were
chosen:

Human Designer

My app menu design already includes “Book-
mark this Tab® under the “Bookmarks™ tab.
What other commands should I include under
this tab?

Please anser in the following format
“TTjson

command name: reason

MenuCraft responds with:

— MenuCraft: Command Recommendation —

Certainly, here are some additional com-—
mands that could be included under the
"Bookmarks" tab with a brief reason for
each:

{

"Bookmark All Tabs": "Enables users to
save bookmarks for all currently open tabs
in a single action.",

"Organize Bookmarks": "Opens a bookmark
manager or dialog that allows users to sort,
categorize, and manage their saved book-
marks.",

"Edit Bookmark": "Lets users modify the
properties of an existing bookmark, such as
the title, URL, or tags.",

"Remove Bookmark": "Deletes a selected
bookmark from the user's list of saved book-
marks.",

"Import Bookmarks": "Allows users to im-—
port bookmarks from a different browser or
bookmarking service.",

"Export Bookmarks": "Enables users to ex—
port their bookmarks to a file or other ex-
ternal location.",

"Bookmarks Sidebar": "Toggles the display
of a sidebar or panel that shows the user's
saved bookmarks.",

"Recently Bookmarked": "Displays a list
of recently bookmarked pages or URLs for
quick access."

}

We found the response quite good. In many cases,
these commands already exist in popular browsers.
They allow users to manage and organize their
bookmarks more effectively.

4.4 Command or Tab Name Recommendation

MenuCraft can help designers generate appropriate
names for commands based on their descriptions



or suggest names for tabs based on the set of com-
mands they contain. For example, asking Menu-
Craft about a menu tab name based on two known
commands inside it:

Human Designer

There 1is a nameless tab on my menu de-
sign that includes commands such as "Min-
imize" and "Zoom". Please suggest top best
10 names for this tab.

MenuCraft responds with:

_ MenuCraft: Tab Name Recommendation —

Sure! Here are ten potential names for the
tab that includes commands like "Minimize"
and "Zoom":

Window, Display, View, Layout, Screen,
Desktop, Workspace, Monitor,
Size & Position, Display Options

These names are intended to convey the idea
of adjusting the window or interface in var-
ious ways, such as changing the size, po-
sition, or arrangement of elements on the
screen. Hopefully, one of these names fits
well with the intended purpose of the tab
and helps users easily locate the relevant
commands .

There are several good suggestions for the desired
tab name in the response. For instance, one can find
both Minimize and Zoom commands in the Window
Tab (MenuCraft’s first choice) of Chrome browser
on MAC OS X.

4.5 Hotkey Recommendation

Hotkeys, also known as keyboard shortcuts, are
a combination of keys on a computer keyboard
that provide a quick way to access various menu
commands. The selection of well-thought-out
hotkeys can speed up access to frequently used
commands. MenuCraft simplifies this process by
creating hotkeys based on menu design, reducing
the time and effort required. Hotkeys must be dis-
tinct from other commands in the app. For example,
continuing the first design of the text editor in sec-
tion 4.1, by requesting to add shortcuts:
Human Designer

Add shortcut for each command, two differet
commands must not have the same shortcut.

MenuCraft responds with:

— MenuCraft: Hotkey Recommendation

Certainly! Here's the updated menu design
for a text editor application with 3 tabs,
including the Find command in the Edit tab,
no more than 6 commands per tab, and key-—
board shortcuts for each command:

{"File": [
{"name": "New", "shortcut": "Ctrl+N"},
{"name": "Open", "shortcut": "Ctrl+O"},
{"name": "Save", "shortcut": "Ctrl+3S"},
{"name": "Save As...",
"shortcut": "Ctrl+Shift+sS"},
{"name": "Print", "shortcut": "Ctrl+pP"},
{"name": "Exit", "shortcut": "Alt+F4"}
1,
"Edit": [
{"name": "Undo", "shortcut": "Ctrl+z"},
{"name": "Redo", "shortcut": "Ctrl+y"},
{"name": "Cut", "shortcut": "Ctrl+X"},
{"name": "Copy", "shortcut": "Ctrl+C"},
{"name": "Paste", "shortcut": "Ctrl+v"},
{"name": "Find", "shortcut": "Ctrl+F"}
1,
"Format": [
{"name": "Font",
"shortcut": "Ctrl+Shift+F"},
{"name": "Bold", "shortcut": "Ctrl+B"},
{"name": "Italic", "shortcut": "Ctrl+I"},
{"name": "Underline",
"shortcut": "Ctrl+U"},
{"name": "Strikethrough",
"shortcut": "Ctrl+Shift+sS"},
{"name": "Highlight",
"shortcut": "Ctrl+H"}

1}

I've added keyboard shortcuts for each
command to make it quicker and easier
for users to access frequently used com-
mands. The shortcuts are listed next to
each command in the format of Ctrl+Key or
Ctrl+Shift+Key.

Most of the selected shortcuts are commonly used
by other applications, such as Ctrl + Z for the
Undo command. The rest is made up of the Ctrl
key and the first letter of the command. To prevent
shortcut reuse, the Ctrl + Shift combination is used.
Nevertheless, an error occurred when assigning the
shortcut for the third time to a command that starts
with the letter S (Strikethrough). MenuCraft can
be instructed about what other templates it can use
to create shortcuts to prevent this from happening.
However, the designer can also inform MenuCraft
of its mistake through more interaction :

- Human Designer

The same shortcut must not be shared
by two commands, even in different tabs.
“Strikethrough™ and “Save As...~ share a
same shortcut.

MenuCraft replies with a thank you for clarifying
and corrects its mistake by replacing the shortcut
for Strikethrough command (other tabs were not
shown for better readability):



MenuCraft: Hotkey Modification

Thank you for the clarification Here's an
updated menu design ensuring that no two
commands share the same shortcut even in
different tabs:

{"name": "Strikethrough",
"shortcut": "Ctrl+Shift+D"},

I changed the shortcut for Strikethrough
to Ctrl+Shift+D to ensure that it does not
share the same shortcut as Save As.... This
will help users avoid confusion and make it
faster to perform specific tasks with the
text editor.

In the revised response, it was suggested to use an-
other shortcut (Ctrl+Shift+D) for the Strikethrough
command. This suggestion is acceptable since pop-
ular applications such as Microsoft Excel also use
the same shortcut.

4.6 Command Elaboration

MenuCraft can provide additional information
about specific commands in a menu. It can explain
the meaning of a command or provide examples
of how it could be used in context. This feature
can assist in verifying whether an intelligence un-
derstands the functionality of a command based
on its name in a given context. Additionally, it
can generate documentation for the designed menu.
For example, continuing the first design of the text
editor in section 4.1 by requesting an elaboration
on designed menu commands:

Human Designer

Provide a short elaboration on the designed
menu commands for the text editor. The for-
mat should be as follows:

tab name, command: short elaboration

MenuCraft responds with:

MenuCraft: Command Elaboration

File Tab:

— New File: creates a new blank document

— Open File: opens an existing file for edit-
ing

— Save: saves the current document

— Save As: allows the user to save the docu-
ment under a different name or file type

- Print: prints the current document

— Exit: closes the application

Edit Tab:

— Undo: reverses the last action performed

— Cut: removes the selected text and copies
it to the clipboard

— Copy: copies the selected text to the clip-
board

— Paste: inserts the contents of the clip-
board at the current cursor position

- Find: searches for a specific word or
phrase in the document

— Replace: allows the user to replace a spe-—
cific word or phrase with another

Format Tab:

— Font: allows the user to change the font,
size, and style of the selected text

— Bold: makes the selected text bold

- TItalic: makes the selected text itali-
cized

— Underline: adds an underline to the se-
lected text

- Strikethrough: adds a strikethrough to
the selected text

— Highlight: highlights the selected text

with a color

Each command has been explained in a fair and
reasonable manner.

5 Conclusion and Future Work

MenuCraft represents a promising new direction in
menu design through language models. Our initial
experiments have shown that MenuCraft can per-
form various menu design tasks quite well. How-
ever, MenuCraft is still in the prototype phase and
needs much more to explore. Moving forward, our
future work with MenuCraft will focus on conduct-
ing additional user studies to gain further insights
into the needs and preferences of menu designers.
This will allow us to tailor MenuCraft to meet the
specific requirements of different users and con-
texts. Furthermore, we will explore how the data
collected from MenuCraft and designer feedback
can be leveraged for better prompt engineering.
Overall, we are excited about the potential of Menu-
Craft and look forward to continuing our work in
this area. This new direction has the potential to
revolutionize menu design and improve the user
experience across a wide range of applications.

Discussion. There is a discussion in the design
community about rethinking the way Al supports
designers (De Peuter et al., 2021). Their view is
that Al should prioritize cooperation over automa-
tion and seek to enhance the creativity and problem-
solving abilities of designers. The challenge is that
design is an optimization problem, but integrat-
ing a human decision-maker into an optimization



process is hard due to the differences in the way
humans and optimizers think and work. Our view
is that MenuCraft has already taken the step on the
path of collaborating with a designer in the design
process due to the following reasons:

1) As MenuCraft core, i.e. ChatGPT is trained
on a large corpus of data, and human feedback is
also used in the training, we expect ChatGPT to
develop a good judge of human designers.

2) Humans are intuitively familiar with conversa-
tional formats, and MenuCraft is capable of follow-
ing instructions posed in a conversational format.

6 Limitations

Language models offer a promising new direction
for menu design, but it is essential to acknowl-
edge their limitations. Language models may lack
domain-specific knowledge for menu design, and
their performance is heavily influenced by the qual-
ity and diversity of the training data used. More-
over, language models may struggle with under-
standing mathematical concepts, particularly when
designers input specific parameters for design fea-
tures. This limitation could result in poor design
recommendations. Furthermore, MenuCraft has
demonstrated acceptable results with ChatGPT, but
extending these results to other LLMs is currently
limited by the lack of experiments with multiple
models.

Note that the current version of the paper lays
out the initial ideas and insights regarding LLMs’
potential role in design. However, we acknowl-
edge that our analysis is primarily limited to cherry-
picked examples to illustrate specific points. In the
future, we plan to conduct more qualitative and
quantitative analysis especially for novel cases that
go beyond the selected examples.

7 Ethics Statement

Our research employed LLMs as menu assistant de-
signers, but owing to limited access and resources,
we are unable to review the LLMs’ training data
or generated data. Therefore, we cannot provide a
guarantee of the absence of discrimination based
on race or sexuality in the LLMs’ content.
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